Please help

Energy One

SGM Hendrix

Member
When I attempted to see if the EHC would reset after cleaning it I connected all the negative wires since it’s a bitch to screw back in Becuase is the frame, and only connect the one wire to the ehc all lights on ehc come on and nothing else. Does it really matter if the other wires are connect.. trying to trouble shoot this damn thing
 

Jersey Big Mike

Well-Known Member
Supporting Member
Guys I am sorry but I am just learning this bike, I will try anything but you have to be specific like talking to a blind man .
Unbolt the coil cover (left hand side opposite of intake/air cleaner)
There are 3 bolts to undo.
Disconnect the JST connector that runs from the switch .

If you have small hands, you might be able to undo the JST connector (little while connector) without pulling cover. It should be towards the front of the coil cover. There will be a little tab to press to release the two halves.

Do you have the manual for the bike? If not you need to get it.
check the tits of the day posts -- one of the regular posters always has the dropbox location of the manuals in his signature line.
 

SGM Hendrix

Member
Ok more information - can’t upload a video of it on here but here is what happens....

when I Connect the EHC wire to the battery and then turn the key on nothing happens the EHC lights up completely the bike does nothing if I take the EHC wire off the battery turn the key on and then apply the EHC wire the bike acts normal everything works and the EHC has only two led lights on.... I have attempted to repeat this several times with the same results when the key is already on and then the wire is placed on the battery the speedo and the EHC act normal if the wire is attached to the battery and then the key is turned on I get nothing
 

Jersey Big Mike

Well-Known Member
Supporting Member
Ok more information - can’t upload a video of it on here but here is what happens....

when I Connect the EHC wire to the battery and then turn the key on nothing happens the EHC lights up completely the bike does nothing if I take the EHC wire off the battery turn the key on and then apply the EHC wire the bike acts normal everything works and the EHC has only two led lights on.... I have attempted to repeat this several times with the same results when the key is already on and then the wire is placed on the battery the speedo and the EHC act normal if the wire is attached to the battery and then the key is turned on I get nothing
I'd still pull that switch.
It's in a Chrome are that you cleaned
It's having an effect on the system.
When you have the switch disconnect you can simulate it by using a jumper across the JST pins.
 
Sorry, got late for me and had to go to bed.
After you go through the cycle of removing the positive lead from the battery, turn the key on and place the positive lead back on the battery have you tried starting the bike and using the functions to see if it locks up again?
 

SGM Hendrix

Member
N
Sorry, got late for me and had to go to bed.
After you go through the cycle of removing the positive lead from the battery, turn the key on and place the positive lead back on the battery have you tried starting the bike and using the functions to see if it locks up again?
o because it was around midnight and I didn’t wanna wake neighbor’s. I will try it after work and report back
 
Also let us know what color the EHC housing is and, if you can read it, what the part number is on the side of the EHC.
If you don't have a service manual for your ride you can get it off Dropbox, there is a link somewhere here on the forum, or just email me, wsworx@gmail.com, and I can email one to you.
 

Jersey Big Mike

Well-Known Member
Supporting Member
No ch

No change
With the cover off you can look and see the ignition switch, follow it till you see a little white connector, disconnect it there and re-attach battery.
If all is good, use a small wire to jump the connector. If all is good replace the switch
 

SGM Hendrix

Member
I have unpluged the white connector and same issue... all lights are on.

I just bought this bike, do you think this is something covered under the warranty? I might just need to have this dog towed and worked on if its covered, and do you think the LED lights i put on her void the warrenty? if so i might need to remove them first
 

woodbutcher

Mr. Old Fart member #145
Staff member
Lifetime Supporting Member
Supporting Member
hate to be the one to tell you, but Big Dog Motorcycles went out of business about 5 years ago.

there is a company called Big Dog is Back that is operated by some of the people associated with the old BDM but there is no coverage for the old bikes.
 
Who did you buy the bike from and did they provide you with a warranty?
Micro-controller lock up is not uncommon with the OEM EHCs when there is outside electrical wired in to the stock harness.
When you put the LED lights in how did they get wired in to the bike's electrical?
If they pulled power off an existing harness circuit it is possible the LED driver is causing issues with the EHC.
I suspect water has gotten into a connector somewhere.
 

SGM Hendrix

Member
i bought the bike from dream machines of austin tx. I am not sure who the warrenty is through i dont have the paperwork with me at work. But i may have to give them a call. its a nation wide warranty so i can take it do a dealer here from my understanding
 

SGM Hendrix

Member
its been disconnect form the battery for over a day now as i didnt want the EHC lights to drain the brand new battery since they are on constant even with out the key
 
It would work short term. I just replaced starter on 09 bulldog for same issue. Plan on having it rebuilt and rechromed and putting it on a shelf just in case.
Yea I’d think for sure it would be much cheaper just to buy a brand new one from shovelheadkicker on eBay rather than go through rebuilding and rechroming an old junk starter, just a thought
 

Jersey Big Mike

Well-Known Member
Supporting Member
hate to be the one to tell you, but Big Dog Motorcycles went out of business about 5 years ago.

there is a company called Big Dog is Back that is operated by some of the people associated with the old BDM but there is no coverage for the old bikes.
If I am not mistaken they are Big Dog Motorcycles, their website is Bigdogisback.com
someone is squatting on the proper domain.
 
Top