Eric's a genius! Daymaker

Th3InfamousI

Admin
Staff member
Supporting Member
Got it figure out ,
The wires were reversed ..
I am a dumbass...
Bright side I now have 3 daymaker headlights
which wires? Probably other guy has same issue.

Well you got enough to last you 20 years now.

It was weird they didnt work for you I've had them in all units available personally no joke. Well except original ehc. Docs, WP, Rip and axles

Sent from my 2PS64 using Tapatalk
 
which wires? Probably other guy has same issue.

Well you got enough to last you 20 years now.

It was weird they didnt work for you I've had them in all units available personally no joke. Well except original ehc. Docs, WP, Rip and axles

Sent from my 2PS64 using Tapatalk
I had the wires messed up from docs headlight harness, I had a pigtail from an old headlight that I pulled out of my spare parts drawer and used it to switch the wires around. As soon as I pulled it out and looked at my setup , I recognized that the wires were not installed properly. Switched them around and sure enough that thing lights up my garage.

The headlight was a little loose in the adjure bucket, I used electrical tape around the black trim of the headlight and put about 3 layers around it, the headlight is fully seated and does not move inside the bucket.
Thanks and the light is awesome especially for the price..
 

Th3InfamousI

Admin
Staff member
Supporting Member
I had the wires messed up from docs headlight harness, I had a pigtail from an old headlight that I pulled out of my spare parts drawer and used it to switch the wires around. As soon as I pulled it out and looked at my setup , I recognized that the wires were not installed properly. Switched them around and sure enough that thing lights up my garage.

The headlight was a little loose in the adjure bucket, I used electrical tape around the black trim of the headlight and put about 3 layers around it, the headlight is fully seated and does not move inside the bucket.
Thanks and the light is awesome especially for the price..
Glad the problem is solved!

Loose? You kept the wave ring in the adjure, right? Mine is tight as hell in the adjure.
Sent from my 2PS64 using Tapatalk
 
My replacement is not due until tomorrow . Probably wont get to until Monday and if it doesnt work I guess I will buy the one LED Bulb that shovelheadkicker has for $40
Check your wires coming from the headlight harness, I found that I had them installed into the plug wrong and that was my issue. Yellow wire is on top, white wire on the left from the front and ground is on the right
 
Glad the problem is solved!

Loose? You kept the wave ring in the adjure, right? Mine is tight as hell in the adjure.
Sent from my 2PS64 using Tapatalk
I did not, Shit
Actually not sure if the ring will fit around light ?
Honestly the electrical tape really keeps it in place and provides a nice seal in between.
May add the ring tomorrow
 

Ernie12

Active Member
Check your wires coming from the headlight harness, I found that I had them installed into the plug wrong and that was my issue. Yellow wire is on top, white wire on the left from the front and ground is on the right

I will check the wires when I take it apart again. Thanks
 

Th3InfamousI

Admin
Staff member
Supporting Member
Do you have the manufacturer's model number? I'm trying to make sure I order the correct one for my 08 pitbull.

Sent from my moto z4 using Tapatalk
 

Jwooky

Well-Known Member
I can share, I have had a couple of these. My first had discoloring and condensation in it. I posted earlier in this thread. They replaced it a couple years ago and so far so good.

Then first time out this year my set screw came out and my light and all the retaining rings fell out. :oldbang:

A guy driving behind me chased us down because he saw the light fly off. He had retrieved it for me thankfully. I threw it in my bag and came home.

The next day I pulled it out and there wasn’t a scratch on it, at least the face, and it worked perfectly.

Donna hooked me up with new rings and back in business.
 

Th3InfamousI

Admin
Staff member
Supporting Member
I can share, I have had a couple of these. My first had discoloring and condensation in it. I posted earlier in this thread. They replaced it a couple years ago and so far so good.

Then first time out this year my set screw came out and my light and all the retaining rings fell out. :oldbang:

A guy driving behind me chased us down because he saw the light fly off. He had retrieved it for me thankfully. I threw it in my bag and came home.

The next day I pulled it out and there wasn’t a scratch on it, at least the face, and it worked perfectly.

Donna hooked me up with new rings and back in business.
In my wreck when the lady hit me, the entire headlight mount broke and the can was hanging by the wires the LED made its way into the 06 I rebuilt still works and not a scratch on it....seems like if you got problems it's quick otherwise these things last and for the price even replacing it every few years is worth it. Although I've had these for for 3-4 years and about 10k on each and no issues.

Sent from my moto z4 using Tapatalk
 
Thanks man, I just ordered one and now I hope I can figure out which size allen to get those pesky set screws out of the bottom of the headlight to remove the Beauty ring bezel and the headlight contents.

Ron
 
Top