2003 Speedo and Odometer Issues

Dogonit

New Member
When I turn the ignition on the needle goes to 60 mph for a second then goes to 0, at the same time the Odometer shows 80,000 miles for a second then shows 1 mile. The needle never moves while the bike is moving and Odometer never changes. My Insurance Co. is going to drop me if I can’t show them it’s registering mileage. What’s the quickest fix? I’m assuming Pro Cycle by Auto Meter Products is the original Speedo.
 

pknowles

semi-retired...---... GURU C7Z06...---...
Lifetime Supporting Member
Supporting Member
Check with member "Butch Cassidy", I think he has a couple for sale.
 

Dogonit

New Member
Check with member "Butch Cassidy", I think he has a couple for sale.
Thank you, I saw that he has 2. It appears the originals are prone to problems, wondering if there is a different Speedo that guys have gone to with success. Not sure if the Speedo is the problem or if it’s the speed sensor. On you tube there is a video that shows if you have a Baker 6 speed you have to install a device to calibrate the Speedo.
 

Dogonit

New Member
Would you happen to have a number for Dakota Digital, they show a handlebar mounted Speedo, I need to know if it is the same as Dash mounted. Thank you
 

HMAN

Just like to ride
Supporting Member
This should be a plug n play replacement. BD-140

 

TomB

Member
I have the same issue with my 06 mastiff. Is the Dakota a simple plug and go?

Sent from my SM-G935P using Tapatalk
 

HMAN

Just like to ride
Supporting Member
I have the same issue with my 06 mastiff. Is the Dakota a simple plug and go?

Sent from my SM-G935P using Tapatalk
Yep, but not sure the same model number will work with your bike. Check the site, they list BDM specific models.
 
Top