Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Running Rough when loaded

Discussion in 'Technical' started by Scrat, Sep 13, 2011.

  1. Scrat

    Scrat New Member

    Joined:
    Sep 13, 2011
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    My Bike(s):
    2005 Bulldog
    First Name:
    Frank
    Hi, new to the forum. Had a friend suggest. I have a issue with the engine. 117 California S&S, on my 2005 Bulldog. When at 70-80 in 6th gear, I get a pulsing of the engine like it is starving for gas. Tried resetting the carb to factory spec's and tuning it in. Runs great when on the throttle or idle, but steady at 70-80 bucks and kicks like it's running out of gas. Any ideas?
     
  2. PaulHart

    PaulHart Well-Known Member

    Joined:
    Apr 17, 2010
    Messages:
    1,143
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Oklahoma
    My Bike(s):
    2009 Mastiff
    First Name:
    Paul
    Assuming your jetting is right and it's got good plugs and wires on it and they're tight. And the battery terminals are clean and tight. I'd pull the petcock and check the screen for trash and make sure you have good fuel flow. After that I'd be pulling the float bowl and jets and cleaning them and making sure the float bowl is adjusted properly and your not sucking the bowl dry.

    What kind of air cleaner/filter do you have on it? Is it stock also?
     
  3. Dezertrider37v

    Joined:
    Jul 26, 2011
    Messages:
    128
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Imperial, California
    My Bike(s):
    2006 Ridgeback
    First Name:
    Craig
    Clean your intermediate jet, if your bike has sat for a bit that's the first thing I'd check.
     
  4. Killerdog

    Killerdog Active Member

    Joined:
    May 19, 2011
    Messages:
    937
    Likes Received:
    8
    Trophy Points:
    0
    Location:
    Arp Texas
    My Bike(s):
    2004 Bigdog Ridgeback
    First Name:
    Doug
  5. aspen874

    aspen874 Well-Known Member
    Supporting Member

    Joined:
    May 25, 2009
    Messages:
    2,240
    Likes Received:
    1,027
    Trophy Points:
    113
    Location:
    Saint Louis, MO
    My Bike(s):
    07 Mastiff 2010 Bulldog Bagger
    First Name:
    Stephen
    What kind of air intake do you have? Some here running a spike air intake have had the same problem that you have described
     
  6. Scrat

    Scrat New Member

    Joined:
    Sep 13, 2011
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    My Bike(s):
    2005 Bulldog
    First Name:
    Frank
    Thanks for the help guys. I put the stock air cleaner back on. I think the spike that the mechanic used did not catch a port on the rear of the mount that I think had something to do with it. Running like a champ now!
     
    Srodden likes this.
  7. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,562
    Likes Received:
    4,133
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    thanks for getting back to us, that is much appreciated. glad to hear it's running the way it should.
     
    Srodden likes this.
  8. firedog19

    firedog19 Active Member

    Joined:
    May 9, 2011
    Messages:
    675
    Likes Received:
    156
    Trophy Points:
    43
    Location:
    Gardner Ks
    My Bike(s):
    2004 ridgeback
    First Name:
    Jan
    If you do not use the stock air cleaner you have to remove the float bowl vent screw in the float bowl. also if you turn the spike vertical it should eliminate the air flow problem they create
     
  9. Scrat

    Scrat New Member

    Joined:
    Sep 13, 2011
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    My Bike(s):
    2005 Bulldog
    First Name:
    Frank
    I may try that, as I really like the look of the Spike, thanks again guys. I am getting ready to do the wire plus EHC change out so I may be on here quite a bit in the near future! :up:
     
  10. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,220
    Likes Received:
    12,435
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    Fuck man.... THIS THREAD IS SIX (6) YEARS OLD!!!!
     
  11. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,220
    Likes Received:
    12,435
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    :whore:


    looks way better pointing forward? That maybe be for you.... not for the majority of us. And, no... don´t start a Poll you now!!! :panic:

    The threads are there for everyone to find them... as they should do, search! It is not nice every time I log in, and look for the new posts/replies, etc, finding OLD threads brought back to life for no reason.

    Thing is, new threads/replies are coming in by the minute... do you really thing that because you brought back to life that old thread someone will see it as soon as they need it????
     
  12. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,220
    Likes Received:
    12,435
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    How, how will they see it??? If who needs the info doesn´t perform a search on the specific subject, will not find it as it will not stay in the first page unless you keep feeding the thread every single day!!!
     
    BWG56 and dentdude36 like this.
  13. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,028
    Likes Received:
    37,051
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Search button don't usually give you what you search for the first time, gotta keep hittin it.:yesnod:
     
  14. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,220
    Likes Received:
    12,435
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    I agree with the search tool in this forum being fing shite, you have to make sure you tick the box "Titles Only" and it gets more accurate. :oldthumbsup:
     
    BWG56 likes this.

Share This Page