Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Read your EHC Fault Lights

Discussion in 'How-To' started by Gas Man, Mar 26, 2008.

Thread Status:
Not open for further replies.
  1. Fibersnake

    Fibersnake Banjo Playing PsychoBilly

    Joined:
    Jun 11, 2007
    Messages:
    4,383
    Likes Received:
    132
    Trophy Points:
    63
    Location:
    Eastern Panhandle of West Virginia
    My Bike(s):
    2005 BD Mastiff 2009 Buell 1125R
    GM,

    Thanks, I did find that earlier doing the search and just forgot to come back and re-post with update. All seems good now!!! :D :D

    Now I can roll on this weekend for Rolling Thunder without having to look down at my oil pressure gauge every 5 secs. :eek:
     
  2. Cuz

    Cuz Member

    Joined:
    Apr 17, 2008
    Messages:
    165
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Irving, Texas
    My Bike(s):
    2004 BD Chopper
    Does anyone have a scan of a 2004 EHC
     
  3. kirk927

    kirk927 Member

    Joined:
    Nov 22, 2007
    Messages:
    111
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Cabarrus Co, NC
    My Bike(s):
    2008 K9, 2002 V-star 1100, 2006 R1
    Thanks for the image upload. I have a question, when looking at the lights, are they supposed to be on for normal operation. If not on, I assume this means there is a problem? Thanks for any insight into this. I can see some of these lights on the EHC and am learning how to read this particular bike.
     
    #23 kirk927, Jun 18, 2008
    Last edited: Jul 13, 2008
  4. kirk927

    kirk927 Member

    Joined:
    Nov 22, 2007
    Messages:
    111
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Cabarrus Co, NC
    My Bike(s):
    2008 K9, 2002 V-star 1100, 2006 R1
    Any thoughts on this request. I posted this some time ago and no replies. Thanks guys.
     
  5. Raywood

    Raywood The Pirate
    Staff Member Supporting Member Calendar Participant

    Joined:
    Apr 5, 2007
    Messages:
    17,356
    Likes Received:
    626
    Trophy Points:
    113
    Location:
    Rainbow, CA
    My Bike(s):
    2014 KMW Regulator
    First Name:
    Ray
    Most of these are fault lites. Except for power and ignition and maybe some others on the newer models all the others are ground fault lites.

    Time to order you a service manual! :D

    :cheers:
     
  6. bdmridgeback

    bdmridgeback Low Down Chop Shop

    Joined:
    Jul 15, 2007
    Messages:
    4,519
    Likes Received:
    59
    Trophy Points:
    48
    Location:
    SW FL
    My Bike(s):
    '05 Ridgeback
    First Name:
    Jake
    That last one is the new one that they put in my 2005 Ridgeback with the USB plug. It has more lights on it than the one with the Serial plug.
     
  7. NJ K-9

    NJ K-9 Member

    Joined:
    Aug 25, 2008
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NJ Close to NYC
    My Bike(s):
    2006 K-9
    First Name:
    Carl
    Hope I'm posting this one in the right place. I've a 2006 K-9 & would like to hook up my laptop to read what's going on inside ( not adjust or change anything ). Can I just plug the USB into my laptop & read (through Word or ???) or do I need some special (BD) software.
    Thanks
     
    #27 NJ K-9, Sep 27, 2008
    Last edited: Sep 28, 2008
  8. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,048
    Likes Received:
    252
    Trophy Points:
    83
    Location:
    Metro Detoilet
    Nope... have to have the BDM software.
     
  9. NJ K-9

    NJ K-9 Member

    Joined:
    Aug 25, 2008
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NJ Close to NYC
    My Bike(s):
    2006 K-9
    First Name:
    Carl
    Who has it, or where can I pirate a copy? 2006 K-9, Wouldn't mind you sending it to Carlmyman@aol.com if you had it.
    Thanks
     
    #29 NJ K-9, Sep 27, 2008
    Last edited: Sep 27, 2008
  10. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    HERE I GO AGAIN !!!!!!!!

    2004 RIDGEBACK, 107" NEWEST EHC. I purchased a NEW EHC with all the extra lights and the two Pin-Connectors married into one that fits my 04.

    anyway, put about 125 Miles on it since updating the EHC. Today after riding for 30 minutes I stopped for lunch. After about 45 minutes started her up and rode for 1/2 mile and the bike just shut off. Didnt sputter more like I shut her down.:angry:

    I get her to the side of the road, and turn the key off and pull it out of the ignition. This is what happened :

    Headlight was off, rear lights were on and the speedo was still lit up like it was running. I pulled the seat, and every light, (YES EVERY LIGHT) on the EHC was lit up like Christmas.

    Put the key back into the ignition switch, attempted to start the bike and nothing. :bang: After about 2 minutes of cursing and wondering what color ROAD KING I was going to buy when I sell this piece of crap, I decided to disconnect the negative post on the NEW battery. All the EHC lights went out.

    Replaced the Negative wire and tightened it down. Put the key into the ignition, and started her up. Ran great all the way home.:up:

    WHAT THE HELL Would cause this ?:bang: :angry: :bang: :angry:

    Getting seriously tired of all the electrical problems that I have with this bike.

    Any thoughts ?????

    Ride safe and have a great weekend:flag:
     
  11. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,048
    Likes Received:
    252
    Trophy Points:
    83
    Location:
    Metro Detoilet
    Have you put anything new electrically on the bike besides the EHC?

    maybe turns or HID?
     
  12. N8KAM

    N8KAM Well-Known Member

    Joined:
    Jan 13, 2008
    Messages:
    1,655
    Likes Received:
    27
    Trophy Points:
    48
    Location:
    S.E Michigan
    My Bike(s):
    05 Mastiff 07 Ultraclassic/Electraglide
    First Name:
    John
    I had the same thing happen this spring after installing the new EHC..
    All the lights on....
    [​IMG]

    Pull the coil / upper mount and see if this resistor is in line.. if so remove it. it is built into the new EHC

    [​IMG]

    The ign key could also be the problem... if the EHC looses power for like 25 ms it goes in to shutdown mode.. and locks up just like your PC.
    here are the links for my experience this spring... I have a new ign switch but haven't installed it yet.... just removed the resistor and 3000+ miles this year with no more problems... Good luck.. John


    http://www.bigdogbiker.com/forums/performance/4036-bike-shut-down-after-40-miles.html

    http://www.bigdogbiker.com/forums/technical/4664-little-diag-help.html
     
  13. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    Thanks

    Thanks "GAS" for the heads up:2thumbs: . I did upgrade to a HID Light. I will replace it with the factory "BIG-DOG" Bulb, first thing Sunday morning when I get home from work.

    And "N8KAM" I will have to check for the resistor. Thanks for the quick reply and info, I appreciate it:cheers: .

    Ride safe
     
  14. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,048
    Likes Received:
    252
    Trophy Points:
    83
    Location:
    Metro Detoilet
  15. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    Yes

    Thanks for the tip "GAS". I actually replaced the battery when I did the switch to a HID Bulb. I'm home now and going to lose the resistor and put the original bulb (Big Dog) back in.

    I will let you guys know how I made out.

    Again, Thanks for all of your help and info. I appreciate it.Have a great day.

    Ride safe:2thumbs:
     
  16. Raywood

    Raywood The Pirate
    Staff Member Supporting Member Calendar Participant

    Joined:
    Apr 5, 2007
    Messages:
    17,356
    Likes Received:
    626
    Trophy Points:
    113
    Location:
    Rainbow, CA
    My Bike(s):
    2014 KMW Regulator
    First Name:
    Ray
    You won't find the resistor on an 04. It was a quick fix on the newer 05 models after several of them melted down. Once the EHC was upgraded the "pigtail" (resistor) is not needed anymore but doesn't do any harm either.

    :cheers:
     
  17. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    NOW YA TELL ME !

    Thanks "Ray". I pulled it all apart and your correct, Nothing. Thanks for the input.

    I pulled the HID Bulb and replaced it with the Factory BigDog Bulb. Taking it for a ride, and I will let you know how I made out with the ride:whoop: .

    Thanks again to everyone for all of the help and info. You guys ROCK:cheers:

    And Thanks to "BIG DOG BIKER", Its like having a Mechanic on call with any problem that you may have.

    Ride safe:flag:
     
  18. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    110 Miles

    Put 110 Miles on the Dog this afternoon. Just arrived home with no problems at all:whoop:

    Thanks for all of your help:up: .

    BIG DOG BIKER AND ALL THE MEMBERS ARE AWSOME:cheers:

    HAVE A GREAT WEEK.

    Ride safe
     
  19. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,048
    Likes Received:
    252
    Trophy Points:
    83
    Location:
    Metro Detoilet
    Need to check with Jake on this if pullin the HID helped.

    Is everything else working well with the bike? No speedo or any other problems?
     
  20. choppersforlife

    choppersforlife CHOPPERSFORLIFE
    Supporting Member

    Joined:
    Apr 9, 2007
    Messages:
    413
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SOUTH JERSEY
    My Bike(s):
    RIDGEBACK / HD STREET GLIDE
    First Name:
    TONY
    All fine so far

    Hey "GAS":

    After replacing the EHC to the newest version, and replacing the Battery, and now replacing the HID Bulb back to the factory BigDog Bulb, all seems Fine.

    No other problems. BUT !

    Not that it's a problem, I noticed on Sunday that the blinking brake lights do not work any longer. The brake lights still operate, but simply a steady light when the brakes are applied. I'm guessing the new EHC took care of that ?

    Thanks agin for all of your help. As usual, "I owe ya":cheers: a few Cold Ones.

    Ride Safe
     
Thread Status:
Not open for further replies.

Share This Page