Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

R.I.P. Gen II EHC kit installed

Discussion in 'How-To' started by 2007EZ, Dec 24, 2015.

  1. jackiev

    jackiev New Member

    Joined:
    Mar 1, 2008
    Messages:
    14
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Southern Calif.
    My Bike(s):
    '05 BD Chopper 117"
    First Name:
    Mommiestoy
    Eric, how did you pull the wires through the hollow tube? I've removed the original (easy, simply cut) but have no idea how to
    pull the new RIP connectors and cable up through the pipe w/o damaging the connectors?
    Thanks
     
    chubs likes this.
  2. KaptinAmerika

    KaptinAmerika Well-Known Member

    Joined:
    Mar 16, 2008
    Messages:
    4,565
    Likes Received:
    1,480
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    2006 Big Dog K9
    First Name:
    Curtis
    LOL.. if you would simply email me I can send you an installation guide.

    wsworx@gmail.com
     
    francoblay1, chubs and dentdude36 like this.
  3. Tomtang aka Reptilejim

    Tomtang aka Reptilejim Well-Known Member

    Joined:
    Feb 2, 2009
    Messages:
    1,320
    Likes Received:
    76
    Trophy Points:
    48
    Location:
    Shreveport, LA
    My Bike(s):
    2006 big dog ridgeback
    First Name:
    Marvin
    Curtis, I received the gaskets yesterday. Thanks!

    Sent from my SM-G900P using Tapatalk
     
    chubs likes this.
  4. KaptinAmerika

    KaptinAmerika Well-Known Member

    Joined:
    Mar 16, 2008
    Messages:
    4,565
    Likes Received:
    1,480
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    2006 Big Dog K9
    First Name:
    Curtis
  5. Tommy Gains

    Tommy Gains New Member

    Joined:
    May 14, 2017
    Messages:
    6
    Likes Received:
    7
    Trophy Points:
    3
    Location:
    Texas
    My Bike(s):
    2004 big dog boxer
    First Name:
    Tommy
    We're can

    Sent from my SM-T230NU using Tapatalk
     
  6. jor43387

    jor43387 Member

    Joined:
    Jul 27, 2017
    Messages:
    38
    Likes Received:
    24
    Trophy Points:
    8
    Location:
    Wisconsin
    Just installed this on my 04 Chop. Took less than two hours and one of those hours was spent talking about the bike.
    Works great. Thanks to Curtis I’m up and running
    Plug and Play!!!!


    Sent from my iPhone using Tapatalk
     
    roadie1389 and HMAN like this.
  7. roadhogg

    roadhogg Member

    Joined:
    Nov 27, 2009
    Messages:
    19
    Likes Received:
    16
    Trophy Points:
    3
    My Bike(s):
    K9
    I got one for you I originally at first put it on it had after week I check it no power,your thoughts,battery is fully charged
     
  8. roadhogg

    roadhogg Member

    Joined:
    Nov 27, 2009
    Messages:
    19
    Likes Received:
    16
    Trophy Points:
    3
    My Bike(s):
    K9
    course now this is a 09 k9
     

Share This Page