Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Help! My new dog died!

Discussion in 'General' started by drK-9, Nov 17, 2017.

  1. drK-9

    drK-9 Member

    Joined:
    Oct 7, 2017
    Messages:
    24
    Likes Received:
    45
    Trophy Points:
    13
    Location:
    Wichita, KS
    My Bike(s):
    16 Streetglide, 07 Softail Custom, 08 BigDog K-9
    First Name:
    Craig
    So we got a little bonus weather day here in Wichita, so I took off work a little early and took the new (to me) 08 K-9 efi out for THE MAIDEN VOYAGE. Everything was perfect, felt like I was on cloud 9, running great, very strong. So about 15 miles into the ride I pulled up to a riding buddy of mine's house to show off a little, he didn't know I got it. We looked it over for a few and off I went, only this time when I started it, it started cutting out, burping and farting, and died after two blocks. Couldn't start it and keep it running for crap, it will make the fuel pump prime up sound, fire up and die, like it is starving for fuel. Well, I pushed it back to my buddies house sad and dejected, pushed it into his garage, and he just brought me home. It's sitting there in his garage won't run for shit. Any ideas??? Thx
    We both have stuff to do tonight, so I guess I'll go over tomorrow with my trailer and pick it up.
     
    chubs likes this.
  2. bdm7250

    bdm7250 Guru
    Supporting Member

    Joined:
    Jun 3, 2016
    Messages:
    7,246
    Likes Received:
    18,801
    Trophy Points:
    113
    Location:
    Hamilton Ontario Canada
    My Bike(s):
    2008 BD Mastiff 2008 AIH Slammer
    First Name:
    Doug
    Bad fuel? Plugged fuel filter? Guessing game with little information.
     
    chubs, Unsprung, Forsaken and 2 others like this.
  3. dentdude36

    dentdude36 Guru

    Joined:
    Nov 9, 2015
    Messages:
    9,221
    Likes Received:
    20,752
    Trophy Points:
    113
    Location:
    Suburbs of Buffalo NY
    My Bike(s):
    2007 K9
    First Name:
    Kevin
    Test battery , Check vfi for codes also sounds like it could be engine temp sensor
     
    Unsprung and BWG56 like this.
  4. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,452
    Likes Received:
    3,965
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    gas cap vent clogged. try unscrewing the cap and listen for a hissing sound.
     
  5. Forsaken

    Forsaken Active Member

    Joined:
    Dec 18, 2016
    Messages:
    513
    Likes Received:
    1,029
    Trophy Points:
    93
    Location:
    Southwest Florida
    My Bike(s):
    2005 Big Dog Chopper
    First Name:
    Gil
    Bummer for your first run....like Doug said, fuel problem??? I think there's a troubleshooting checklist on the forum....get it and let us know what you find.
     
    chubs and dentdude36 like this.
  6. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,839
    Likes Received:
    39,672
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    :agree: with #2, #3 and #4
     
    bdm7250, Unsprung and dentdude36 like this.
  7. drK-9

    drK-9 Member

    Joined:
    Oct 7, 2017
    Messages:
    24
    Likes Received:
    45
    Trophy Points:
    13
    Location:
    Wichita, KS
    My Bike(s):
    16 Streetglide, 07 Softail Custom, 08 BigDog K-9
    First Name:
    Craig
    I just talked to one of my mechanic buddies he thinks I may just have fouled a plug.... sure hope that's it.
     
    chubs likes this.
  8. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,452
    Likes Received:
    3,965
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    right behind a bad vent, that would be what i would want to hear about. cheap fix! good luck.
     
    chubs likes this.
  9. Brandon Downey

    Brandon Downey Active Member

    Joined:
    Aug 22, 2017
    Messages:
    532
    Likes Received:
    626
    Trophy Points:
    93
    Location:
    Anderson, IN
    My Bike(s):
    2007 Big Dog Mastiff
    First Name:
    Brandon
    Not to insult your intelligence in any way shape or form, but how much fuel is in it? If low it may need switched to reserve and fueled up.
     
    chubs likes this.
  10. Brandon Downey

    Brandon Downey Active Member

    Joined:
    Aug 22, 2017
    Messages:
    532
    Likes Received:
    626
    Trophy Points:
    93
    Location:
    Anderson, IN
    My Bike(s):
    2007 Big Dog Mastiff
    First Name:
    Brandon
    Ahhh ok good to know. Thanks. I think I need an efi bike to park next to my carb bike
     
    Unsprung and chubs like this.
  11. dentdude36

    dentdude36 Guru

    Joined:
    Nov 9, 2015
    Messages:
    9,221
    Likes Received:
    20,752
    Trophy Points:
    113
    Location:
    Suburbs of Buffalo NY
    My Bike(s):
    2007 K9
    First Name:
    Kevin
    The thought of efi is nice but it seems that s&s carb is much more reliable the s&s efi not just in big dogs but ironhorse and other custom applications
     
    kickstart and bigkelk9 like this.
  12. drK-9

    drK-9 Member

    Joined:
    Oct 7, 2017
    Messages:
    24
    Likes Received:
    45
    Trophy Points:
    13
    Location:
    Wichita, KS
    My Bike(s):
    16 Streetglide, 07 Softail Custom, 08 BigDog K-9
    First Name:
    Craig
    I'm going to try replacing the spark plugs first this morning. What kind of operation is it to pull the tank, and change the fuel filter? Thx
     
    chubs likes this.
  13. bigkelk9

    bigkelk9 Well-Known Member
    Supporting Member

    Joined:
    Sep 7, 2015
    Messages:
    3,121
    Likes Received:
    5,511
    Trophy Points:
    113
    Location:
    Southeast Texas / Southern California
    My Bike(s):
    07 big dog k9
    First Name:
    Kel
    I think u might have an issue with the fuel pump itself. There is a bike here locally that had the same issue and it turned out to be a fuel pump, another member here who don't visit n e more had a 2010 bulldog bagger, had the same issue.. Idk specs for pressure, but if u can find em I would test pressure first. Just guessing from what I've read and what seems to be a common EFI issue.. good luck brother
     
  14. Unsprung

    Unsprung In the Potters hand...
    Supporting Member

    Joined:
    May 18, 2015
    Messages:
    1,284
    Likes Received:
    2,632
    Trophy Points:
    113
    Location:
    Ruskin, FL
    My Bike(s):
    08 K9, 06 Hayabusa, (wife's ride)
    First Name:
    Gerald
  15. drK-9

    drK-9 Member

    Joined:
    Oct 7, 2017
    Messages:
    24
    Likes Received:
    45
    Trophy Points:
    13
    Location:
    Wichita, KS
    My Bike(s):
    16 Streetglide, 07 Softail Custom, 08 BigDog K-9
    First Name:
    Craig
    Well, just replaced the spark plugs, yes they needed it, but no dice. Damn thing still won't run. I can hear the fuel pump prime up, it fires up, and poops out. Trailered it home. Looks like the tanks coming off...
     
    chubs likes this.
  16. bdm7250

    bdm7250 Guru
    Supporting Member

    Joined:
    Jun 3, 2016
    Messages:
    7,246
    Likes Received:
    18,801
    Trophy Points:
    113
    Location:
    Hamilton Ontario Canada
    My Bike(s):
    2008 BD Mastiff 2008 AIH Slammer
    First Name:
    Doug
    Did you try running it with the gas cap off?
     
    chubs likes this.
  17. drK-9

    drK-9 Member

    Joined:
    Oct 7, 2017
    Messages:
    24
    Likes Received:
    45
    Trophy Points:
    13
    Location:
    Wichita, KS
    My Bike(s):
    16 Streetglide, 07 Softail Custom, 08 BigDog K-9
    First Name:
    Craig
    Yes I took gas cap off and tried that.... no go
     
  18. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,452
    Likes Received:
    3,965
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    did you check to see how much power you have coming out of the coil to the plugs? may just not be hot enough.
     
    chubs likes this.
  19. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,174
    Likes Received:
    4,213
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Could be clogged fuel tank or lines.
     
    chubs likes this.
  20. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,857
    Likes Received:
    16,144
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    X2

    Worth checking out. Put a fuel injection gauge on and see if it holds pressure on the rail

    Sent from my 2PS64 using Tapatalk
     
    chubs likes this.

Share This Page