Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

EHC

Discussion in 'EFI Topics' started by Fossys, May 7, 2017.

  1. Fossys

    Fossys New Member

    Joined:
    Apr 15, 2012
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    My Bike(s):
    Big Dog Chopper 2005
    First Name:
    Fossy
    Had a nice ride with my bid dog 2005, then I put it in the garage. Next day I wanted to drive again but she does not start ....... fuck. No more spark.
    In the ignition module always lights the red lamp which only flashes when it runs. Does somebody has any idea?
    Many thanks in advance Fossy
     
    chubs likes this.
  2. dentdude36

    dentdude36 Guru

    Joined:
    Nov 9, 2015
    Messages:
    8,405
    Likes Received:
    19,401
    Trophy Points:
    113
    Location:
    Suburbs of Buffalo NY
    My Bike(s):
    2007 K9
    First Name:
    Kevin
    This should get you the help you need

    http://www.bigdogbiker.com/threads/your-introduction.25016/
     
    francoblay1, chubs and bdm7250 like this.
  3. PROFLYER

    PROFLYER SWOLE
    Supporting Member

    Joined:
    Oct 8, 2007
    Messages:
    1,899
    Likes Received:
    921
    Trophy Points:
    113
    Location:
    Denver, CO
    My Bike(s):
    06 K9, 06 Mastiff (wife's)
    First Name:
    Sutton
    Lots of threads here covering this so please do some reasearch. Also @KaptinAmerika www.wildsteedworx.com can test your EHC if you think it's that. Could be many things. Search around and start trouble shooting.

    And go introduce yourself or the intro cops will be on you, all 437 of them :D
     
    francoblay1, chubs and dentdude36 like this.

Share This Page