Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

EHC issue or turn signal control board?

Discussion in 'EFI Topics' started by cajun1, Jun 19, 2017.

  1. cajun1

    cajun1 Member

    Joined:
    Oct 26, 2010
    Messages:
    150
    Likes Received:
    120
    Trophy Points:
    43
    Location:
    Eunice Louisiana
    My Bike(s):
    2005 Bigdog Bulldog
    First Name:
    John
    Having an issue which seems to be no power to the right side control switches on my 05 bulldog, The left side switches all work fine. I was wondering if this could be an EHC issue are just an issue with the right side control board and is there any tricks to test which one it might be?
     
    chubs likes this.
  2. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,031
    Likes Received:
    37,057
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Pull the hand control apart and jump the wires to see if you get the functions to work that are not working now
     
    bdm7250, chubs and TapioK like this.
  3. shansel88

    shansel88 Member

    Joined:
    Feb 27, 2016
    Messages:
    89
    Likes Received:
    114
    Trophy Points:
    33
    Location:
    Jacksonville FL
    My Bike(s):
    2004 Chopper
    First Name:
    Sam
    That is the tightest wiring on the bike- has connector that plugs into harness under the tank and it stretches when turning bars. Just verify the connector under the tank is connected. Just my opinion.
     
    Billy413 and chubs like this.
  4. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,031
    Likes Received:
    37,057
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    No wires should be stretching when turning the bars
     
    chubs and TapioK like this.
  5. cajun1

    cajun1 Member

    Joined:
    Oct 26, 2010
    Messages:
    150
    Likes Received:
    120
    Trophy Points:
    43
    Location:
    Eunice Louisiana
    My Bike(s):
    2005 Bigdog Bulldog
    First Name:
    John
    Thanks for the info.
     
    chubs likes this.
  6. bdm7250

    bdm7250 Guru
    Supporting Member

    Joined:
    Jun 3, 2016
    Messages:
    6,620
    Likes Received:
    16,621
    Trophy Points:
    113
    Location:
    Hamilton Ontario Canada
    My Bike(s):
    2008 BD Mastiff 2008 AIH Slammer
    First Name:
    Doug
    :agree: Prolly best place to start.
     
    chubs and TapioK like this.
  7. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,699
    Likes Received:
    10,806
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    If the board is bad, send it to me and I'll see if I can fix it.
     
    chubs likes this.
  8. Billy413

    Billy413 Member

    Joined:
    Sep 24, 2016
    Messages:
    121
    Likes Received:
    148
    Trophy Points:
    43
    Location:
    Schuylkill haven PA
    My Bike(s):
    05 ridgeback
    Yes, check for power and ground at the switch wires on the bars, if you get no ground or power then pull off tank and check if it's unplugged.
     
    chubs likes this.

Share This Page