Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Brake lights

Discussion in 'Ignition / Electronics / Batteries' started by Big Dog 44, Jul 24, 2017.

  1. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    I'm having issues with brake lights not working, turn signals work and parking lights. Also all the LED bulbs are not lit up? Can't figure why it ain't working? Help....

    Sent from my XT1585 using Tapatalk
     
  2. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,434
    Likes Received:
    10,102
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    3 things you need to check. 1. make sure the tire hasn't rubbed through the wire under the fender. 2. the light itself is burned out, but probably not though. 3. Does it not work with both switches, foot and hand.
     
  3. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    No, it doesn't work with both. But turn signals work.

    Sent from my XT1585 using Tapatalk
     
  4. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,434
    Likes Received:
    10,102
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    Being that is an 03, I would think you have a wire broke under the fender. Common for that year. Unplug the harness at the front of the rear fender, and check to see if you have power there.
     
  5. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Thanks, will do and get back with you.

    Sent from my XT1585 using Tapatalk
     
  6. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,811
    Likes Received:
    39,617
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Sounds like the LED bulb to me. if some of them are working but not all. If it was a wire it wouldn't just light up a few of the LED's, its all or nothing
     
    cdogg556 likes this.
  7. cdogg556

    cdogg556 Guru

    Joined:
    May 21, 2011
    Messages:
    7,078
    Likes Received:
    15,360
    Trophy Points:
    113
    Location:
    Folsom, Ca.
    My Bike(s):
    2009 Big Dog Mastiff, Chrome Package, DOC's ESC, 585 cam, VH Big Radius Exhaust, 2.5" fwd cntls.
    First Name:
    John
    :agree:
     
    BWG56 likes this.
  8. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Would a few burn out bulbs on rear stop lights make signal cancellation stop working?

    Sent from my XT1585 using Tapatalk
     
  9. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,811
    Likes Received:
    39,617
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Get new LED lights and install them and eliminate that possibility.
     
  10. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    10-4, Thanks

    Sent from my XT1585 using Tapatalk
     
    BWG56 likes this.
  11. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Well boys, bought new LEDs and installed them, but brake lights still not working, any suggestions what to check next? Turn signals work and parking lights also, but no brake lights.

    Sent from my XT1585 using Tapatalk
     
  12. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,434
    Likes Received:
    10,102
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    Sounds like you have a broke wire somewhere. Start my unpluging the wires at the front of the rear fender, and see if you have power there.
     
  13. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Ok

    Sent from my XT1585 using Tapatalk
     
  14. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,434
    Likes Received:
    10,102
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    If you don't have it fixed by Labor Day weekend, I'll come down there and help you.
     
  15. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,852
    Likes Received:
    16,118
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    First time seeing this thread..should have measured voltage on Turn signal wires and power wire before buying these LED.

    Power wire has plus +12v for runners and turn signal wire will have +12v when brakes are hit or ittemitant signal for turn. They use the same wire. So either born the front and rear brake switch are bad or the EHC crapping out on ya.

    Great diagnostic write-up in the manual

    [​IMG]

    Sent from my 2PS64 using Tapatalk
     
    bigkelk9 and Forsaken like this.
  16. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Thank you Amigo, hopefully I'm back riding by that time.

    Sent from my XT1585 using Tapatalk
     
    bigkelk9 likes this.
  17. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Where is are switches located?

    Sent from my XT1585 using Tapatalk
     
  18. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,434
    Likes Received:
    10,102
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    On the 03's their at at the master cylinders.
     
  19. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    Ok, will try to locate.

    Sent from my XT1585 using Tapatalk
     
  20. Big Dog 44

    Big Dog 44 Member

    Joined:
    Oct 4, 2015
    Messages:
    34
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Austin, Tx
    My Bike(s):
    2003 Mastiff
    First Name:
    Frank
    To all my BD buddies, does anyone have a old ehc for 03 Mastiff for sale?

    Sent from my XT1585 using Tapatalk
     

Share This Page