2007 bulldog starting problems

Gathering
Okay I have searched on this site for the last 2 hours. Bike Road great all summer, the weather has been decent the last week in the 50s, when to start bike it will kick over but cuts out. Hazard flashing lights come on, check engine light comes on, while trying to start it and puffs of smoke come out of the air cleaner. Using non ethanol gas, batteries charged, plugs are good change them anyway just to double-check. Any help would be greatly appreciated

Sent from my SM-G900P using Tapatalk
 

Reddickracing

Well-Known Member
If my bike struggles to turn over the hazards will flash and will stop trying to turn over. I turn the key off and it resets, sometimes it cranks and sometimes it does it again. I put a new battery in which helped tremendously but I also found out my compression releases are not staying down but a sec and a half. Bout to replace them in the next few weeks. Idk if that helps you are not
 

TapioK

Well-Known Member
Okay I have searched on this site for the last 2 hours. Bike Road great all summer, the weather has been decent the last week in the 50s, when to start bike it will kick over but cuts out. Hazard flashing lights come on, check engine light comes on, while trying to start it and puffs of smoke come out of the air cleaner. Using non ethanol gas, batteries charged, plugs are good change them anyway just to double-check. Any help would be greatly appreciated

Sent from my SM-G900P using Tapatalk
Hazards also flash and horn tries to honk when there is not enough voltage on battery, did you check the voltage while pushing start?
 

TapioK

Well-Known Member
If my bike struggles to turn over the hazards will flash and will stop trying to turn over. I turn the key off and it resets, sometimes it cranks and sometimes it does it again. I put a new battery in which helped tremendously but I also found out my compression releases are not staying down but a sec and a half. Bout to replace them in the next few weeks. Idk if that helps you are not
If I remember correctly the compression releases are originally supposed to stay open about that time. Just enough to get over first pressure... some have rewired them to stay open as long as starter is running. There is a how to somewhere...Sorry I don’t have time to look for it now
 

Reddickracing

Well-Known Member
Yea my horn would try to make a sound too. Like I said when it put the new Throttle X 500 CCA battery in it helped a lot. I was told on here that the releases are supposed to stay down until it cranks idk. But they are original and gonna replace them any way.
 
Yea my horn would try to make a sound too. Like I said when it put the new Throttle X 500 CCA battery in it helped a lot. I was told on here that the releases are supposed to stay down until it cranks idk. But they are original and gonna replace them any way.
Thanks I will try that when I get home and check the volts on the battery

Sent from my SM-G900P using Tapatalk
 
Thanks I will try that when I get home and check the volts on the battery

Sent from my SM-G900P using Tapatalk
Yes the voltage went down when I tried to start it it showed 12.48 and then when I try to start it it drop down to 7 to 8 and 1/2. It was a new battery the beginning of Summer did not have it on a trickle charge, but charged it with a regular battery charger once a month maybe I need to get a trickle charger or Tender

Sent from my SM-G900P using Tapatalk
 

TapioK

Well-Known Member
Yes the voltage went down when I tried to start it it showed 12.48 and then when I try to start it it drop down to 7 to 8 and 1/2. It was a new battery the beginning of Summer did not have it on a trickle charge, but charged it with a regular battery charger once a month maybe I need to get a trickle charger or Tender

Sent from my SM-G900P using Tapatalk
That POS is dead. Get a new one, most likely it still has warranty
 

Reddickracing

Well-Known Member
Yes the voltage went down when I tried to start it it showed 12.48 and then when I try to start it it drop down to 7 to 8 and 1/2. It was a new battery the beginning of Summer did not have it on a trickle charge, but charged it with a regular battery charger once a month maybe I need to get a trickle charger or Tender

Sent from my SM-G900P using Tapatalk
Look up "What to do if starter wont turn" by Moespeeds, its prob the thread that Eric is referring to. I looked at it briefly and looks to be very informative.
 

BWG56

Guru
I think that was an upgrade if you ditched the EHC. If memory serves me right the original EHC just gave them juice for 1.5 seconds. MoeSpeeds did a how to on wiring them to the solenoid wire.

Sent from my 2PS64 using Tapatalk
No not 1.5 seconds, the manual stated 1.0 seconds:Don the OEM
 

Th3InfamousI

Administrator
Staff member
Lifetime Supporting Member
Supporting Member
Axel got back to me and informed me that with his ehc the compression releases are engaged as long as the start button is in use/pressed..... figured I'd share the info
That's good to know too! Sounds like all the new stuff has resolved a timing issue that BigDog thought up for no reason.

Sent from my 2PS64 using Tapatalk
 

Hambone

New Member
Help! I'm new to this. Tried to start my 07 K-9 (with a new battery) and all I get is the horn screaming at me. What do I check?
 

HMAN

Just like to ride
Supporting Member
Help! I'm new to this. Tried to start my 07 K-9 (with a new battery) and all I get is the horn screaming at me. What do I check?
Put a charger on the "new" battery overnite and try again. Not all new batteries are fully charged and these Dogs need all the CCA they can get. Jm .02
 
Top