BIG DOG Motorcycles Forum  
Go Back   BIG DOG Motorcycles Forum > Big Dog Motorcycles > Technical

Technical Technical related discussions.

Reply
 
LinkBack Thread Tools Display Modes
Old 07-28-2008, 08:29 PM   #1 (permalink)
Member
 
Rick's Avatar
 
Member #: 225
Join Date: Oct 2007
Location: Parker, CO
Posts: 302

My Bike(s): 2006 BD K-9 1990 Honda Transalp


Rep Power: 7
Rick will become famous soon enough
How do you check for a bad Speedo Sensor?

Speedo died on a recent 2500 mile trip. Got home removed speedo sensor and cleaned it off (wasnt that dirty). Speedo is still not working. Or should I say the speedo works but when moving the needle doesnt move and the odometer doesnt count milage. Speedo goes up to 60 and back to 0 when key turned on. Lights in speedo work and it does the self test. only thing I can think of thats wrong is maybe the speedo sensor took a crap. Diagnostics that Gas sent me says test Speedo Sensor. How do you test the speedo sensor? I would like to just iorder a replacement if that is the problem and install myself.

Rick
__________________
Rick is offline   Reply With Quote
Old 07-28-2008, 09:46 PM   #2 (permalink)
Member
 
Daddycool's Avatar
 
Name: Marc
Member #: 1081
Join Date: Jun 2008
Location: Broken Arrow, Ok.
Posts: 778

My Bike(s): 2005 Big dog Chopper


Rep Power: 7
Daddycool is an unknown quantity at this point
Mine did the same thing... check your battery. I know it sounds funny... I thought so to, but I have not had a problem since I put in a battery back in November. Good luck! Marc
Daddycool is offline   Reply With Quote
Old 07-28-2008, 09:58 PM   #3 (permalink)
Member
 
Rick's Avatar
 
Member #: 225
Join Date: Oct 2007
Location: Parker, CO
Posts: 302

My Bike(s): 2006 BD K-9 1990 Honda Transalp


Rep Power: 7
Rick will become famous soon enough
Thanks but I know it's not the battery. It's fully charged and on a battery tender everyday. Bike cranks over fine just no speed.
__________________
Rick is offline   Reply With Quote
Old 07-28-2008, 11:14 PM   #4 (permalink)
The Pirate


 
Raywood's Avatar
 
Name: Ray
Member #: 3
Join Date: Apr 2007
Location: Rainbow, CA
Posts: 16,930

My Bike(s): 2014 KMW Regulator

My Garage

Rep Power: 5
Raywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the rough
Rich, has your EHC had the flash upgrade yet? If not you can get it done at the BDM truck in Sturgis or at your dealer. Been solving a lot of problems witht he Speedo.
You will know it's flashed it the speedo sweeps to 60 and back twice. Once when turning the key on and another when you hit the run button.


__________________
2014 KMW Regulator

Rode hard and put away wet

RATT Bike = "Rode All The Time"


<center>
<a href="http://www.mytriplogs.com" target="_blank">
<img src="http://www.mytriplogs.com/sigs/mtl_odo_gen.php?odo=000000" border="0"></img>
<br>56,551</a>
<br>
</center>
Raywood is offline   Reply With Quote
Old 07-28-2008, 11:38 PM   #5 (permalink)
Member
 
Rick's Avatar
 
Member #: 225
Join Date: Oct 2007
Location: Parker, CO
Posts: 302

My Bike(s): 2006 BD K-9 1990 Honda Transalp


Rep Power: 7
Rick will become famous soon enough
Thanks Ray I will talk to my dealer tomorrow about that. My speedo only sweeps once, when the key is turned on. Is the flash upgrade a service bullitan? If so what number? If not do I just ask the dealer about the EHC flash upgrade?
__________________
Rick is offline   Reply With Quote
Old 07-28-2008, 11:42 PM   #6 (permalink)
The Pirate


 
Raywood's Avatar
 
Name: Ray
Member #: 3
Join Date: Apr 2007
Location: Rainbow, CA
Posts: 16,930

My Bike(s): 2014 KMW Regulator

My Garage

Rep Power: 5
Raywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the roughRaywood is a jewel in the rough
Quote:
Originally Posted by Rick View Post
Thanks Ray I will talk to my dealer tomorrow about that. My speedo only sweeps once, when the key is turned on. Is the flash upgrade a service bullitan? If so what number? If not do I just ask the dealer about the EHC flash upgrade?
Don't know if it's a service bullitin or not but they are flashing everyones EHC that has a USB port that will cause your speedo to sweep two times as a way of knowing it was done.
But it's not done on all bike such as mine that still has the serial plug.
I suggest getting with your dealer or authorized service center.

Did I miss it or are you not going to Sturgis?????

See ya,
Ray
__________________
2014 KMW Regulator

Rode hard and put away wet

RATT Bike = "Rode All The Time"


<center>
<a href="http://www.mytriplogs.com" target="_blank">
<img src="http://www.mytriplogs.com/sigs/mtl_odo_gen.php?odo=000000" border="0"></img>
<br>56,551</a>
<br>
</center>
Raywood is offline   Reply With Quote
Old 07-29-2008, 11:49 AM   #7 (permalink)
lee
Senior Member
 
lee's Avatar
 
Member #: 269
Join Date: Nov 2007
Location: Bristol, England
Posts: 4,806

My Bike(s): 2005 Bulldog and 2002 HD Heritage

My Garage

Rep Power: 10
lee is a jewel in the roughlee is a jewel in the roughlee is a jewel in the roughlee is a jewel in the roughlee is a jewel in the roughlee is a jewel in the rough
Quote:
Originally Posted by Rick View Post
Thanks but I know it's not the battery. It's fully charged and on a battery tender everyday. Bike cranks over fine just no speed.
that doesn't necessarily mean this issue isn't caused by your battery

if you get going down the road for a few minutes and then stop and shut off at the key, then restart, does that remedy the speedo problem? If it does then I would say its your battery.
lee is offline   Reply With Quote
Old 07-29-2008, 12:05 PM   #8 (permalink)
Member
 
Rick's Avatar
 
Member #: 225
Join Date: Oct 2007
Location: Parker, CO
Posts: 302

My Bike(s): 2006 BD K-9 1990 Honda Transalp


Rep Power: 7
Rick will become famous soon enough
Tried that and speedo still doesnt move.
__________________
Rick is offline   Reply With Quote
Old 07-29-2008, 12:44 PM   #9 (permalink)
OLD DOG
 
reloaderbmg's Avatar
 
Name: IAN
Member #: 265
Join Date: Nov 2007
Location: maitland fl.
Posts: 1,250

My Bike(s): 2007 k9,2003 road king

My Garage

Rep Power: 7
reloaderbmg will become famous soon enough
the flash with the usb. port i thought was for ign. !
old software had it that if a bulb or wire would short out, it would take the whole bike down, [engine shut off]
this just isolates the ign.
__________________
ian
reloaderbmg is offline   Reply With Quote
Old 07-29-2008, 12:49 PM   #10 (permalink)
OLD DOG
 
reloaderbmg's Avatar
 
Name: IAN
Member #: 265
Join Date: Nov 2007
Location: maitland fl.
Posts: 1,250

My Bike(s): 2007 k9,2003 road king

My Garage

Rep Power: 7
reloaderbmg will become famous soon enough
to test speedo sensor, remove from top of trans,
key on, and after self test,move a metal screew driver "close" back & forth in front of it, if speedo does not jump or move , repl, sensor!
__________________
ian
reloaderbmg is offline   Reply With Quote
Old 07-29-2008, 03:52 PM   #11 (permalink)
SWOLE
 
PROFLYER's Avatar
 
Name: Sutton
Member #: 191
Join Date: Oct 2007
Location: Denver, CO
Posts: 1,418

My Bike(s): 06 K9, 08 CBR 1000RR


Rep Power: 7
PROFLYER has a spectacular aura aboutPROFLYER has a spectacular aura aboutPROFLYER has a spectacular aura about
hmmmm...I was with Rick when this happened, my speedo only sweeps once as well! Mine works though!
__________________
'06 K9 landscape flames
XXX'd
THUG Intake
HID
.585 V Thunder cam
MGS Tornados
Custom Baffles/Custom Tune
114.4hp/125.1lb. ft.

www.SuttonCavalier.com
PROFLYER is offline   Reply With Quote
Old 07-29-2008, 04:01 PM   #12 (permalink)
Member
 
holyrollerboy's Avatar
 
Member #: 1250
Join Date: Jul 2008
Location: Honolulu
Posts: 127

My Bike(s): 2007 K-9; 2007 HD Deluxe; Kawasaki ZX-14


Rep Power: 7
holyrollerboy is an unknown quantity at this point
My K-9 did that the dealer changed out the speedo....Hopefully you are still under warranty?../ extended warranty?..
__________________
07' Big Dog K-9 07' HD Deluxe 07' Kawasaki ZX-14 Can't bench 300!... but I did bowl a 300! .....and ride on a 300 size tire with my K-9
holyrollerboy is offline   Reply With Quote
Old 07-29-2008, 09:56 PM   #13 (permalink)
Cool isn't cheap

 
Gas Man's Avatar
 
Member #: 5
Join Date: Apr 2007
Location: Metro Detoilet
Posts: 15,040



Rep Power: 20
Gas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of lightGas Man is a glorious beacon of light
The software upgrade to the EHC will allow the speedo to reset again when you lift off the start button. You will see the needle sweep again.

This was to relieve some problems with low voltage on the batteries affecting the speedo working.

Check the sensor... try reloader's idea
__________________
^^My $0.02 not yours^^

-Chris
aka Gas Man
"Why pay somebody else to fuck up your bike?"

"DEATH SMILES AT ALL OF US --- ALL I CAN DO IS SMILE BACK!" -Al Sensoli
Gas Man is offline   Reply With Quote
Old 07-30-2008, 12:41 PM   #14 (permalink)
Member
 
CCRainman's Avatar
 
Member #: 49
Join Date: Apr 2007
Location: Somewhere in Jersey
Posts: 1,433

My Bike(s): 09 Street Glide FLHX


Rep Power: 8
CCRainman has a spectacular aura aboutCCRainman has a spectacular aura aboutCCRainman has a spectacular aura aboutCCRainman has a spectacular aura about
Swap out a sensor with some that has a BD and try it. It takes on a minute to swap out, then you'll know if that is the problem. Simple and cheap.
__________________
Don't Go 55 and You'll Stay Alive
CCRainman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On



All times are GMT. The time now is 01:13 AM.


Copyright 2007-2014, Big Dog Biker

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
Ad Management plugin by RedTyger

Showcase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.